Get in touch
Back
Maintenance

Migration of Game Hosting control panel

Completed 23 Feb at 12:15am GMT.

Control Panel
Completed

The migration has now been completed. If you face any issues please open a support ticket.

Posted 23 Feb at 12:15am GMT.
Started

We will be migrating the Game Hosting control panel to a new node, during this time the panel will be unavailable. Please note your servers will be unaffected.

Posted 22 Feb at 11:30pm GMT.